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 1 Get started 

1. Get started 

Log in and access a course 

1. Open a web browser and navigate to www.moodle.is.ed.ac.uk  

2. Click on the red Login with EASE button and login if prompted. 

The Moodle Dashboard will load. Moodle is divided into two columns. The narrower 
column on the left displays small boxes called blocks. Blocks display navigation links 
and supplementary information such as the calendar and news.  

The Navigation block is always at the top left – it provides a useful way to move around 
within Moodle.  

The breadcrumb trail appears above the Navigation block and can be useful to find 
your way around Moodle. 

On the right is the content area, which on the Dashboard page displays an overview of 
the courses you have access to. 

 

All Moodle teachers have access to the Staff Moodle Help course, which contains 
resources to support people creating Moodle courses.  

Tip: You can change the layout of the My courses page, including which courses are 
displayed in the Course overview, by clicking on the Customise this page button. 

  

http://www.moodle.is.ed.ac.uk/
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1 Get started 

Choose a course format 

Tip: If you are attending a training session the instructor will advise you which course to 
use for the practical sessions. If you are working through this workbook in your own time 
you can use any playground course that you can access as a teacher. If you do not have 
access to a playground course please email is.helpline@ed.ac.uk and request that one 
is set up for you. 

There are six course formats available in Moodle: 

 Grid format – Replaces the topics with a grid of icons (one for each topic) with 

short titles. 

 Single activity format – The course consists of a single activity, for example a 

Quiz or SCORM package. 

 Social format – A forum is displayed on the course page. 

 Collapsed Topics – The course page is organised into topic sections that can be 

expanded or collapsed. 

 Topics format – The course page is organised into topic sections. 

 Weekly format – The course page is organised into weekly sections, with the first 

week starting on the course start date. 

1. On the Moodle Dashboard page, click on the name of the course you want to 

edit. This will take you to the course’s home page. 

2. Find the Administration block and click Edit Settings. 

 

Here you can change your course’s name and summary information. 

3. Under Course start date choose today’s date. 

4. Click to expand the Course format section. Under Format choose Topics 

format. 

5. Under Number of sections choose 3 from the menu. 

6. Go to the bottom of the page and click on the Save and display button. 

Tip: The Course layout option allows you to switch between displaying the whole 
course on one page (Show all sections on one page) and displaying each topic on a 
separate page (Show one section per page). 
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 1 Get started 

Add names and summaries to topics 

Each topic box has an area at the top where you can put a heading or title for that topic 
section. As well as the numbered topics there is also an unnumbered section above 
them that can be used for a subheading and general information about your course. 

1. Click on the Turn editing on button at the top right of the content area. 

 

2. In the heading section above the topics, click on the Edit menu and choose Edit 

section. 

 

3. Un-tick the Use default section name box. 

4. Type Polar Bears in the Section name box. 

5. Type ‘Everything you ever wanted to know about polar bears.’ in the Summary 

box. 

6. Click on the Save changes button. 

7. Using the Edit menu each topic, rename the three topics as ‘Resources’, ‘Map’ 

and ‘Video’. 

8. Click the Turn editing off button at the top right of the course’s home page. 

Your course will look something like this:  
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2 Add basic resources 

2. Add basic resources 

Files 

You can add any sort of file that you want your students to download - for example Word 
documents, PowerPoint presentations or PDFs. 

1. Turn on editing.  

2. Click on Add an activity or resource in the Resources topic. 

 

3. Choose File (towards the bottom of the list), click the Add button. 

4. Enter the Name ‘Document 1’ and the Description ‘Test document’ for the file 

you will be adding. 

5. Drag a Word document file onto the blue arrow in the Select files area; release 

your mouse button when the text changes to “Drop files here to upload”. 

Alternatively you can click on the Add… button to choose a file to upload. 

 

6. When the file has uploaded, click the Save and return to course button at the 

bottom of the page. 

7. Find and click on the Document 1 you just added to the Resources topic and 

check that it opens in Word. 

 

Tip: You can also add files by dragging and dropping them directly into a topic on the 
course home page. This only works with editing on. 
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 2 Add basic resources 

URLs 

1. Check that editing is still turned on.  

2. Click on the Add an activity or resource in the Resources topic, choose URL 

and click Add. 

3. Enter the Name ‘Polar Bears International website’ and the Description 

‘Conservation through research, stewardship, and education’. 

4. Enter www.polarbearsinternational.org in the External URL box. 

5. Click to expand the Appearance section and choose In pop-up from the Display 

menu. 

6. Click the Save and return to course button at the bottom of the page. 

Tip: You are advised to open external URLs in pop-ups because it is considered to be 
the most accessible of the four available options. 

Your Resources topic will now look like this: 

 

It is good practice to tell people if a URL is going to open in a pop-up window – we will 
add a label to do this in chapter 3. 
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2 Add basic resources 

Images 

There isn’t a specific option to add an image in Moodle so we will add one using the 
Label resource. 

1. Open http://tinyurl.com/polar-bear-map in a web browser and save the image 

Polar_bear_range_map.png to your computer. 

2. Go to your Moodle training course and check that editing is turned on. 

3. Click on Add an activity or resource in the Map topic. Choose Label and click 

Add. 

4. In the Label text editor click on the Insert/edit image icon. 

 

5. Click on the Find or upload an image… button. 

 

6. The File picker will open, make sure that Upload a file is selected. 

7. Click on the Browse… button, locate the Polar_bear_range_map.png file and 

click Open. 

8. Delete the text in the Author field so it is blank and change the Choose license: 

drop-down menu to Public domain. 

http://tinyurl.com/polar-bear-map
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 2 Add basic resources 

This image came from the Wikimedia Commons website, where it is explicitly stated it is 
in the public domain. Be aware of the copyright status of images downloaded from the 
internet. 

9. Click on Upload this file. 

10. Type ‘Map showing Polar Bears’ range in the Arctic’ in the Image description, 

then click the Insert button. 

Tip: It is important that you include a useful image description to improve accessibility for 
visually impaired people using screen readers 

11. In the Label text editor, press return to create a new line under the image and 

type ‘Map of Polar Bears’ Range’ as the image title. 

Text below the image could also be used to display any copyright information. 

12. Click the Save and return to course button at the bottom of the page. The map 

image should be displayed in the second topic. 

 

The image looks too big on the page.  

13. To change the image size, click on the Edit link at the top right of the image. 

Choose Edit settings from the menu. 
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2 Add basic resources 

14. Click once to select the image in the Label text editor and click on the Image 

button.  

15. Click on the Appearance tab, make sure the Constrain proportions box is 

ticked and type 200 in to the first Dimensions box. The second box should 

automatically update when you click outside the first box. 

16. Click Update. 

17. Click Save and return to course. 
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 2 Add basic resources 

Videos 

Tip: Media Hopper, the University of Edinburgh’s media management service, has a 
Moodle plugin. If you want to add videos from Media Hopper to your Moodle course you 
can find full instructions in the Staff Moodle Help course.  

1. Check that editing is turned on. 

2. Click on Add an activity or resource in the Video topic. Choose Label and click 

Add. 

3. In a new browser tab, go to www.youtube.com. Find the video you want, click on 

the Share button, then Embed, and copy the embed code. 

4. Return to the Moodle tab. In the Label text editor, click on Toolbar toggle. 

 

5. Click on the Edit HTML source button. 

 

6. Paste the YouTube video embed code into the HTML source editor. 

7. Click the Update button. 

You can embed YouTube videos in your course as you are not making a copy of the 
video, just linking to it. Make sure you consider the copyright of any other sort of video 
you want to include. 

8. Click the Save and return to course button at the bottom of the page. 

9. Play the video embedded in the Video topic.  

http://www.youtube.com/
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2 Add basic resources 

Moodle pages 

A Moodle course does not have to be just the home page - you can add pages to the 
topics. Pages are a useful way to add information without making the home page very 
long. Reading lists, videos and images can all be put on their own page. 

1. Check that editing is turned on. 

2. In the Resources topic, click on Add an activity or resource. Choose Page and 

click Add. 

3. Type ‘Reading List’ for the page Name and ‘Books to read’ as the Description.  

In the Page content editor type ‘Andrew, M. (1990). Nanook the polar bear’.  

Enter a new line and type ‘Wikipedia Polar Bear Article (this link opens in a new 

window)’.  

4. Select Wikipedia Polar Bear Article and click on the Link button. 

 

1. In Link URL type ‘http://en.wikipedia.org/wiki/Polar_bear’. 

2. Choose Open in a new window from the Target menu. 

3. Click on the Insert button. 

4. Click the Save and return to course button at the bottom of the page. 

5. Click on the Reading List link to view the page. 
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 3 Improve the appearance of your course 

3. Improve the appearance of your course 

Add labels 

1. Check that editing is turned on and you are on the course home page. 

2. In the Resources topic, click on Add an activity or resource. Choose Label 

and click Add. 

3. Type ‘The following link will open in a pop-up window:’ in the Label text editor. 

You can make changes the font such as bold, italic, superscript, using the buttons at the 
top of the Label text editor. These are similar to the usual Microsoft Word formatting 
commands. Click on the Toolbar Toggle button to display them all: 

 

Tip: If you want to have headings, use the heading styles in the Format menu as this 
improves accessibility.  

 

If you know HTML you can use the Edit HTML source button to edit the page in HTML: 

 

4. Click on Save and return to course. 

The Resources topic should look similar to this: 
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3 Improve the appearance of your course 

Move resources 

1. Check that editing is turned on. 

2. Click and hold the Move resource (crossed arrows) icon next to the “The 

following link…” label in the Resources topic. 

 

3. Drag the link so that it is above the Polar Bears International website URL 

before releasing it. 

The Resources topic should now look like this: 
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 3 Improve the appearance of your course 

Hide topics and resources 

Both whole topics and individual resources can be hidden in Moodle. This can be used 
so that students cannot see areas you are working on. Students can’t see hidden 
resources, but other teachers can.  

1. Check that editing is turned on. 

2. Click the Edit menu at the top right of the Video topic and choose Hide topic. 

 

3. Click the Edit menu to the right of the Document 1 file in the Resources topic 

and choose Hide. 

 

4. In the Administration block, click Switch role to…, then Student. 
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3 Improve the appearance of your course 

 

You are now viewing your course as a student – notice that neither the Video topic, nor 
the Document 1 file link, is visible. 

5. Click Return to my normal role in the Administration block.  

6. Turn editing on again and click Edit > Show topic next to the Video topic and 

choose Show from Document 1’s Edit menu to make them visible again. 

Tip: By default hidden topics are listed as “Not available”. To completely hide hidden 
topics ensure you are on the course home page, then choose Edit settings in the 
Administration block. Expand the Course format section and choose Hidden sections 
are completely invisible from the Hidden sections menu. 
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 4 All about blocks 

4. All about blocks 
Blocks appear to the left (and sometimes right) of the main Moodle content. They usually 
take information from another part of your course (such as a glossary or forum), or from 
an external site (such as a RSS feed).  

You can set the order of blocks in each column. Students cannot add, delete or move 
blocks but they can hide them or put them into the dock.  

Some blocks need configuring before they will display information. 

Hide and dock blocks 

1. Click once on the Hide block icon at the top right of the Navigation block (top 

left) to hide it. Click again to show it. 

 

2. Click on the Dock icon in the Navigation block to dock it on the left side of the 

screen. 

 

3. Hover over Navigation in the dock and click on the Undock icon to move the 

block back to the main area. 
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4 All about blocks 

Add and delete blocks 

1. Check that you are on the course home page and that editing is turned on. 

2. Find the Add a block block at the bottom of the left column. Choose Course 

Contents from the menu. 

3. Click on the Actions (cog) icon in the Table of contents block. Choose 

Configure Table of Contents block from the menu. 

 

4. Expand the On this page section and note the Region and Weight menus.  

The Region determines whether the block appears to the right or left of the content area. 

The Weight determines where the block appears in the column. The lower the weight the 
higher the block will appear in the column, relative to the weights of the other blocks in 
the column. It is not recommended that you choose a position above the Navigation or 
Administration blocks, as these important blocks should to be easy for users to find. 

You can also set the block’s default region and weight in the Where this block appears 
section. This affects how it appears on other pages. 

5. Click the Cancel button. 

Tip: You can also move a block by dragging and dropping when editing is on (click on 
Move icon the block’s blue header). 

To delete a block: 

1. Check that editing is turned on. 

2. Click the Actions icon of the block you want to delete. Choose Delete from the 

menu. 

3. You will be asked if you are sure that you want to delete the block, click Yes. 
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 5 Creating accessible courses 

5. Creating accessible courses 
It is important to make sure that your Moodle course is as accessible as possible for 
disabled users. Accessible content will be more useable and therefore benefit all users. 
This page has important advice from Information Services about how to create an 
accessible virtual learning environment (VLE) course: 

http://edin.ac/1PrFQqF  

Any PDFs, Word documents, PowerPoint presentations or other files that you include in 
your Moodle course should also be accessible. This page has advice about creating 
different types of accessible materials: 

http://edin.ac/1iLC9SG  

6. Help resources 

Staff Moodle Help course 

All Moodle teachers have access to the Staff Moodle Help course, which contains 
resources, including forums and frequently asked questions, to support people creating 
Moodle courses: 

https://www.moodle.is.ed.ac.uk/course/view.php?id=15  

Moodle help 

Use the Moodle Docs for this page link at the top right of every page in Moodle to see 
context-specific help. 

 

Helpline 

If you have any problems using Moodle please contact Information Services’ Helpline: 

 Web: Self-service portal http://ed.unidesk.ac.uk/tas/public (preferred) 

 Email: IS.Helpline@ed.ac.uk 

 Phone: +44 (0)131 651 5151 

 Availability: IS Helpline is open 24 hours a day, 7 days a week 

 

http://edin.ac/1PrFQqF
http://edin.ac/1iLC9SG
https://www.moodle.is.ed.ac.uk/course/view.php?id=15
http://ed.unidesk.ac.uk/tas/public
mailto:IS.Helpline@ed.ac.uk

